element-ui 安装报错 npm WARN saveError ENOENT 等信息

 2019-06-15 18:58:30   {{zan}}   68 

在安装 element-ui 的时候出现下面这样的报错:

image.png

主要是两个问题:1、是缺少 package.json 这个文件;2、是缺货少 vue@^2.5.17 ,挨个解决。

1. 上面两个错误是说缺少 package.json 这个文件,解决办法就是添加这个文件:

npm init -y

执行上面代码后,再执行:

npm i element-ui -S

执行后,可能会出现如下错误:

image.png

就是 package.json 中没用 description 和 repository,那就添加上这两个:(少什么加什么)

{
  "name": "package.json",
  "version": "1.0.0",
  "main": "index.js",
  "dependencies": {
    "element-ui": "^2.9.1",
    "vue": "^2.6.10"
  },
  "devDependencies": {},
  "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1"
  },
  "author": "",
  "license": "ISC",
  "keywords": [],
  "description": "caohongyuan", ## 这里是添加的 description
  "repository": {               ## 这里是添加的 repository
    "type": "",
    "url": ""
  }
}

然后再执行:

npm i element-ui -S

应该只剩下一个错误了:

image.png

2. 告诉我们要安装这个 vue@^2.5.17,那我们就安装这个:

npm install vue@^2.5.17

然后再执行:

npm i element-ui -S

就没有报错了。


欢迎评论指导!

提交 清空